Outlook: Your IMAP server wants to alert you to the following: Application-specific password required

Outlook and Gmail problem: “Application-specific password required”

Last updated on | 33 replies

You’re sure you’ve entered the correct password but this error “Your IMAP server wants to alert you to the following: Application-specific password required” keeps coming up? This may be because your Google Account has 2-Step Verification enabled and your normal password will not work.

1. Generate an Application-specific password

  1. Visit your App passwords page. You may be asked to sign in to your Google Account. (If you see a message “The setting that you are looking for is not available for your account.” – this means 2-Step Verification is not enabled on your account. Enable it first.)
  2. At the bottom, click Select app and choose the app you’re using.
  3. Click Select device and choose the device you’re using.
  4. Select Generate.
  5. Follow the instructions to enter the App password (the 16 character code in the yellow bar) on your device.
  6. Select Done.

2. Allow access to your Google Account

As a security precaution, Google may require you to complete an additional step when signing into a new device or application using an application password.

Visit the Display Unlock Captcha page and click Continue.

Google Display Unlock Captcha

Complete the CAPTCHA if you are prompted.

If your account was unblocked, you should see a message Account Access Enabled.

Google Account Access Enabled

You can now use your new Application-specific password for Outlook.

Let me know if this helped. Follow me on Twitter, Facebook and YouTube, or 🍊 buy me a smoothie.

p.s. I increased my AdSense revenue by 200% using AI 🤖. Read my Ezoic review to find out how.

33 replies

Leave a reply

Your email address will not be published. Required fields are marked *

  1. I have been looking for a solution to this problem all day. Finally found you and thank you so much for your info, I can now access my gmail via Outlook 2007. xx

  2. Thanks a lot. It worked for me.
    Question: Do I need to generate a new application psw every time I closethe outlook on my PC ?

  3. thank you so much!!! after days of frustrastion and searching for the right answer, your suggestion worked… woohoo

  4. it works…save me a lot of time.
    i even not aware that i need to enter the application password and try my gmail password for hundred times…. 🙂

    Many thanks for simple and clear instruction!

  5. Hi. when adding a new account into outlook it still brings up a screen telling you username or password is incorrect when do a test email on the account. tx Stan

  6. worked at first but next day I start my computer outlook asked for password again.
    Why did they have accounts and passwords, and then need to generate random passwords nobody can remember? it’s a joke and a reason to go away from google. it’s that simple account/password and give me my mail. I have a second paid google biz account and same problem there. Solution for me is only not using outlook for now.

  7. Yes, I switched on this 2 step authentication in gmail, and I appeared to have no problem, but when I went to my office PC which is using Win7 Pro and Outlook/Office 2010, I had to switch off 2 step authentication in order to use my Imap via Outlook.

  8. All I get is:
    Something went wrong and outlook could not save your account settings
    when I enter the 16 digit code, tried manual and paste. I did notice that Outlook is not an option for app choice so I picked mail

  9. Thanks, everything went perfectly according to plan, until I input the newly generated password in Oulook settings and got a “something went wrong….” response over and over. So still no Gmail in Outlook…. And that infuriating password box popping up every 30 seconds when Outlook is open!

    1. Are you typing your Google Account password or your Application-specific password? Have you tried pasting the password instead of typing?

  10. Sorry, not helpful. when i generate the password (easy) and go to account, there’s only a choice for Accounts and Import, not just accounts. when I select the thing I think is my account, it only lets me select a different reply to address. there’s no place ot enter the pasword